Aviation Forums Forum Index Aviation Forums
Aviation discussions newsgroups
 
Archives   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

rotax 477 flooding, help?

 
Post new topic   Reply to topic    Aviation Forums Forum Index -> Light aircraft
View previous topic :: View next topic  
Author Message
rprovins10
Guest





PostPosted: Mon Jan 19, 2004 7:22 am    Post subject: rotax 477 flooding, help? Reply with quote



quicksilver mx, rotax 477, bing carb, inverted engine, pulse operated pump,
fuel tank behind seat, float & mixture set to spec from rotax web site, fuel
pump new, diaphram ok, primer is squeeze bulb type.
compression good, spark >1/4 inch (points), air filter clean (new). choke
plunger seal clean/new.
engine starts very badly, back spark plug fills with fuel instantly and
quits, front cyl runs only below 1/3 throttle, otherwise floods too.
any suggestions?

Robert Provins




Back to top
Jim Williamson
Guest





PostPosted: Mon Jan 19, 2004 1:37 pm    Post subject: Re: rotax 477 flooding, help? Reply with quote



"rprovins10" <rprovins10 (AT) earthlink (DOT) net> wrote:

Quote:
quicksilver mx, rotax 477, bing carb, inverted engine, pulse operated pump,
fuel tank behind seat, float & mixture set to spec from rotax web site, fuel
pump new, diaphram ok, primer is squeeze bulb type.
compression good, spark >1/4 inch (points), air filter clean (new). choke
plunger seal clean/new.
engine starts very badly, back spark plug fills with fuel instantly and
quits, front cyl runs only below 1/3 throttle, otherwise floods too.
any suggestions?

Could the fuel bowl floats be bad and allow an overfill via the carb?

If tin/plastic style float shake them and listen to fuel inside (or are
they heavy). If cork style make sure they float and are not saturated.

Back to top
Mark Smith
Guest





PostPosted: Mon Jan 19, 2004 2:07 pm    Post subject: Re: rotax 477 flooding, help? Reply with quote

rprovins10 wrote:
Quote:

quicksilver mx, rotax 477, bing carb, inverted engine, pulse operated pump,
fuel tank behind seat, float & mixture set to spec from rotax web site, fuel
pump new, diaphram ok, primer is squeeze bulb type.
compression good, spark >1/4 inch (points), air filter clean (new). choke
plunger seal clean/new.
engine starts very badly, back spark plug fills with fuel instantly and
quits, front cyl runs only below 1/3 throttle, otherwise floods too.
any suggestions?

Robert Provins


do you not have the standard root tube tank ?

also, do you have primer ?

a primer bulb is a misnomer since it merely fills the bowel and does not
introduce any 'prime' into the engine,

it may doush the whole works if the main needle/seat/floats are bad
though, and the rear cylinder gets the drain due to the engine tilt when
on the tailskid,

rebuild the carb, get a seal kit, they are 24 bucks, includes ne float
needle, seals, etc,
no jetting per se,

also, check the iddle jet for clogginh, a main caus eof poor idle and
starting,

lose the choke,

get a prime rpump that squirts fuel into the carb neck, both cylinders ,
an atomizes it too,

I get first pull starts with most of my engines, using only the primer
pump,

no primer bulbs ar they have a bad tendency to plug up, leak, dryrot,
etc, clod the system with debris form the dryrot,,,,,,,,
--


Mark Smith
Tri-State Kite Sales http://www.trikite.com
1121 N Locust St
Mt Vernon, IN 47620 mailto:mark (AT) trikite (DOT) com

Back to top
Display posts from previous:   
Post new topic   Reply to topic    Aviation Forums Forum Index -> Light aircraft All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB